Make Discord ACTUALLY start minimized when it's supposed to

Kommentarer

12 kommentarer

  • SadFrogMemer

    1 year later, this is still an issue that never got resolved... Should I make a new thread to try to boost awareness?

    3
  • Reynard D. Fox

    Yes.

    3
  • klyde

    Still not fixed

    1
  • Ozama

    Still not fixed in 2022 bruh

    1
  • .floatingsunfish

    This is very annoying. I'm thinking of uninstalling the Windows app just because of this issue.

    Please fix it! It should be relatively simple!

    4
  • J4UNE

    Exactly! This is annoying. When I turn on my computer in a hurry, while trying to get my work done, a gray screen appears for a few seconds.

    2
  • Rofii

    2 years and it's still like this. The only solution is to disable starting discord with windows, and only launch it when you need to use it. You'd think they would want users to have it open as much as possible.

    1
  • Danyil

    I have a workaround solution for windows without any pop-ups.
    Press Win+R. Write shell:startup in prompt.
    Create a new shortcut there. Place path to Discord.exe with --start-minimized parameter.
    Resulted string should look like this
    C:\Users\Danyil\AppData\Local\Discord\app-1.0.9012\Discord.exe  --start-minimized
    (remember to change Username and check your app version)
    As last step disable auto start in discord app to remove default entry.
    Congrats! You no longer have to wait many years for Discord devs to fix this.
    This method probably disables auto-update on launch, which I find to be behavior I like more. Just make sure to press green update button from time to time if you see it in your discord app.

    1
  • Particle

    Thanks for the tip Danyil

    Unfortunately it doesn't seem to work for me. I made a shortcut to Discord.exe and added the --start-minimized parameter, but it still opens a fullscreen blank window for a few seconds when I launch it :(

    I even tried the Run: Minimized option in the shortcut properties but that doesn't seem to accomplish anything either.

    0
  • meliodastablet

    Particle Danyil or anyone else interested, here is another workaround solution that works even when you update the app and the folder name changes due to version number change:

    Create a new text document and paste this inside:

    @echo off
    setlocal
    
    :: Set the Discord directory path
    set "DiscordDir=%LocalAppData%\Discord"
    
    :: Find the latest version folder in Discord directory
    for /d %%i in ("%DiscordDir%\app-*") do set "LatestVersionDir=%%i"
    
    :: Check if Discord.exe exists in the latest version directory
    if exist "%LatestVersionDir%\Discord.exe" (
        :: Launch Discord with --start-minimized parameter
        start "" "%LatestVersionDir%\Discord.exe" --start-minimized
    ) else (
        echo Discord.exe not found.
    )
    
    endlocal

    Now save the text file with a name of your choice and change the extension from .txt to .bat

    Press Win+R. Write shell:startup in prompt. Copy and paste your newly created bat file to that folder. Don't forget to disable “auto start” from the discord app. That's it.

    PS: You can see a windows appear and disappear for a second, that is our bat file running. A lot better imo :)

     

    0
  • Gleb Salmanov

    So, I was in the process of cleaning up my Windows install and fixing annoying things about it, and I remembered about Discord being unbearably annoying in this way…

    I tried using the --start-minimized option, but it doesn't seem to always work. For instance, if Discord has any updates queued up, or wants to show you some banner announcement that, out of all the billions upon billions of people, not a single human being in the history of mankind had any desire to see, it will ignore the option and proceed to open its interface.

    It doesn't help that you have to run this wall of text of a script directly above this comment to even start it up with this option.

    I propose a different solution. Or, rather, a different bodge, because of course, the only thing that counts as a solution is Discord getting their act together and fixing this. In the meantime, I think the easiest and most robust thing to do, is use AutoHotkey (v2):

    WinWait "ahk_exe Discord.exe", , 600, "Updater"
    WinMinimize
    Sleep 300
    WinClose

    The script above waits 600 seconds (10 minutes) for a window with a process name “Discord.exe” but without the word “Updater” in the window title to appear, then sends a ‘minimize to taskbar’ signal to it, waits for 300 milliseconds for minimization to complete, and then sends a ‘close’ signal to the window, to finally minimize Discord to tray.

    The reason the script needs to minimize the window first, is that WinClose doesn't work quite smoothly: the window flashes one to two times in rapid succession before actually being closed. Thus doing a WinMinimize first is more pleasing to the eye.

    If you have the ‘Minimize to Tray’ option unchecked in Discord settings, you can also just remove the last two lines of the script, and it will work just fine.

    Lastly, the script, although being more hackish, is arguably more robust, because it implements the functionality that it strives to achieve all by itself. It will only break if Discord decides to change its startup sequence in some significant way, or rename the updater window. Which they probably won't.

    And even if don't want to have AutoHotkey installed on your PC for all of this to work, I have good news for you. AutoHotkey scripts can be compiled into relatively compact exe files. You can just compile the script and uninstall AutoHotkey when you're done, if you don't want it to stay on your PC. 

    0
  • Oomek

    It's been 4 years and this is still not fixed? Pathetic devs.

    0

Log ind for at efterlade en kommentar.