Screen Share doesn't play sound

Answered

Comments

18 comments

  • Official comment
    Waterloo

    Hi, sorry you're having this problem. Our team is aware of the problem with screen sharing audio from the Google Chrome app. We're currently working on a fix and you can review this article for more detail: https://support.discordapp.com/hc/en-us/articles/360032665831

    However, since this website is for suggestions on new features to add to Discord I'm closing out this ticket as invalid.

  • Emily

    Having technical issues with Discord? If you have valid reproduction steps (you know how to make the issue happen every time), head over to https://discord.gg/discord-testers and submit a report. Otherwise, hit up support at https://dis.gd/contact for assistance

    -2
  • undermaster
    Hello there! I'm sorry you're having that problem! If you would like help troubleshooting your issue, please contact Discord support here: https://dis.gd/contact.
    -3
  • LoxyTheReindeer

    My friend is having the same exact problem. We don’t know why this is happening, but no matter what they try no audio will come through. If anyone comes up with a solution please let me know.

    1
  • T-gamer

    My friend is mad at me because of this we just wanted to watch netflix over dc ;-;

    1
  • odenset

    T-gamer If you just want to watch netflix other than from where you are, you can use socks proxy. It's similar to VPN, but you only need a PC on the access point (in this case your friend's computer). You don't need to pay any money.
    First, you'll need to setup ssh port forwarding from your fiend's computer to yours.
    Second you'll need to install the "proxy helper" extension on your chrome.
    Third, you'll need to setup proxy setting from the options menu of "proxy helper" plugin.
    That's it. enjoy your show!

    0
  • xinbenlv

    My use case is to run a online karaoke party and would like to be able to play the sound back into the streaming.

    0
  • Host PC

    Has this been resolved or a work around developed? Because it's still not working.

    0
  • Lorik

    Try disabling this if it's on, in User Settings >> Voice & Video

    3
  • Klairm

    Any way to get this working?

    0
  • ashhley

    Has anyone figured this out?

     

    0
  • StickyKeys

    The solution above didn't work and my Voice Settings don't have the options listed above. AllI want to do is be able to use my headphones when screensharing. Sometimes, I don't want the sound to go through my apartment while it's going. I don't get why this doesn't work. 

    1
  • Hasdify

    Also, make sure you are streaming an application, not a screen!

    -4
  • oh my

    streaming an application doesnt make any difference

     

    0
  • lilith

    i use discord canary to stream now. i dont know if it works for other people but using discord canary works for me

    0
  • sabz

    I am sorry but it has been 2 years, how has this not resolved yet? ( at least for Mac users) if anyone know how to fix this and uses Mac pls let me know! Thank you.

    0
  • FattyMcButterPants (PC/NA)

    The issue has been fixed. Make sure you are not Sharing a screen but instead stream the actual game you are playing. Then you'll be prompted with the following.

    -4
  • sunnysawrav

    I'm sorry but it isn't fixed. When I am sharing my screen, I want to be able to play sound from whatever app I select and not just from the specific app. Don't get me wrong, it is good to have that option but I want to be able to stream complete computer system sound.

    7

Please sign in to leave a comment.