Many bot messages blocked when "Link Preview" setting is off



  • Erzzy

    I agree with this. As a bot developer, I don't want to implement embeds into my bot if it means some people won't be able to see them at all. I also have link previews off and have been very confused.

    Some options:

    • Simply make bots immune to the settings option. They are certainly not "link previews" so this makes sense.
    • Separate the settings into two options, though an option that more or less only hides bot messages would be a strange one.
    • Have something clickable that can expand or collapse previews and/or embeds, similar to the small triangle on Slack.
    • Allow bots to send a message that gets displayed instead of the embed for users who hide it.
  • LordNyriox

    I feel like there needs to be more of a spotlight on this issue.

    I did not realize that it was the "link preview" option causing the bot post contents to be hidden until after I had already opened a support ticket to ask if any setting could possibly have this effect. The person who responded seemed rather confused, so I started testing settings one by one until I found it myself.

    If this issue was more widely publicized, a Google search would have actually been useful in diagnosing the problem.

  • pensan

    Same problem here. I was wondering why the bot messages didn't show up for me, but for everyone else.

    This should have a higher priority for the dev team, since a lot of server use bots to apply roles after 'reading the rules and react with an emoji'.

  • Shadow

    It's a very old issue, I had made a similar request ages ago on the former Feedback platform that's gone now.

    The use of embeds is on rise nowadays (with slash commands and stuff) and due that this setting is past due to be split. It makes no sense. I agree it needs more awareness.

    Apparently it's due some internal coding, both link previews and embeds are rendered the same way (just open Element Inspector and see that both use the same structure).


Please sign in to leave a comment.