Error: Cannot find module "discord_desktop_core"

Comments

39 comments

  • ShadyLeon

    Hey, I have the same problem two days ago and I dont know what to do

     

    -2
  • Smash?!

    same have reinstalled and done everything

    1
  • GetJackd

    Hey y'all i say you try and change the build version

    To do this open your run app ( you can find it by typing in run in your search bar at the bottom)

    once your run app is open type appdata, then click on local, and then discord

    after you have it open click app-0.0.308, then resources, then click build_info and open it with notepad

    After you have it open change "version": "0.0.308" to "version": "0.0.306"

     

    36
  • ☢𝕝𝕠𝕖𝕛𝕖𝕖☢

    GetJackd AWESOME! it worked, thanks!

    0
  • fazmade

    that fix doesnt work and now the whole resources folder is empty

    0
  • dread

    GetJackd Thank you a lot that worked, how do you even figure stuff like that out?

    0
  • ThEventual

    GetJackd you'r my hero

     

    0
  • Flower

    You can try going to C:\Users\AppData\Roaming\discord

    and then delete everything in there. (You'll have to resign into your discord).

    Once you have done that, reopen discord and it'll reinstall itself

    9
  • SeiaDoon

    Flower,

     

    Thanks!  This actually worked for me.  Unlike the others I hadn't even been able to reinstall, it would just give the same error.  Deleting out the Roaming\discord data did the trick.  Installed and logged back in.  Thanks mate!

    0
  • Sandpai

    Blueflower 's fix worked for me, discord reinstalled itself real quick and the issue's not popping up anymore.

    2
  • Avatar_Shane

    GetJackd you are an absolute god send, thank you!!

    0
  • sigge.i

    I reinstalled discord but can not download it again what should a do

    -1
  • J-Son

    @sigg.i Just delete the 2 discord folders in: C:\Users\AppData\Roaming\ AND  C:\Users\AppData\Local\. You should be able to reinstall discord. You shouldn't have to re-download. Just locate where your downloads folder is and run the application again.

    0
  • kikota06

    te quiero GetJackxd gracias

     

    0
  • DeveloCraft

    WOW thank you GetJackd 

    0
  • DriedBuffulo0

    GetJackd 

    Worked like a charm If you are having this problem try his method. 

    0
  • Erkan 1337

    Thx so much Flower it was very helpful

    0
  • LucaCP

    OMG GetJackd thx works

    0
  • lynxx

    GetJackd thanks man it worked great

     

    0
  • v1ntage

    GetJackd dude you are actually such a bro, I thought I was gonna have to do some stuff to my drivers

    -2
  • riri

    help it still wont work and i dont know how to get to C:\Users\AppData\Roaming\ pls help

    0
  • qTay

    riri go to your file explore and type %appdata% and delete the discord folder and re-install discord. This is a clean install which will make the discord set_up create all new files

    0
  • [Will. S]

    Thanks jack, changing .309 to .308 changed my life

    0
  • Tha WhiteFang

    So I did what GetJackd said but it didn’t work. So all I did was open build_info with notepad again and changed the 6 back to an 8 and now everything works

    0
  • Dantemaycry20

    thanks i had this issue today and that fix was easy to understand and fixed quikly

     

    0
  • IveGotThePower

    ✅ I was able to fix this problem.

    I've followed this guide which finally helped me to fix the issue with my discord installation, its very helpful: https://www.questionary.wiki/en/questions/software/discord-error-cannot-find-module-discord_desktop_core

    1
  • braylon

    Discord is not installing, I have been trying for 4 hours and have tried every trick on the internet because everyone says the same thing, I have deleted the roaming and local stuff, reinstalled dc about 20 times now, restarted my pc, I get the failed to extract installer error when launching the setup exe, so I extract the setup with 7zip. I extract the nupkg and then go to lib, net45, and then I launch the exe. I get a error that states, "Cannot find discord desktop core". and I click ok, then nothing happens, no one has a fix that works for me from what I have seen. Let me know your thoughts. *sadge*

    2
  • teddy

    yo man im having the same problem please let me know if you find a fix

    1
  • Castello

    braylon exactly same as you man, did you fixed ? really need helps, tryied those 2 methods and dont work ! sorry for bad english

    2
  • feelsbadman

    has anyone found a fix yet ??? the methods of flower and getjackxd didnt work 

     

    0

Please sign in to leave a comment.