right click option no longer working



  • Mastrix | Xtra

    im having the same problem

  • 木棉花

    I've been experiencing the same issues for the past few days too. 
    When I right click the message box, nothing pops up and I have to resort to keyboard shortcuts to paste images or text.  

  • Amaguq

    This is really annoying, I use multiple build-in dictionaries from my browser and I can't change between them because of this bug, and I call it a bug because sometimes right click actually works.

  • Akiko

    omg SAME. Please fix, Discord!!

  • Derikson

    Same issue here!!!!!!! Cant Right click & paste anything, Cant right click & copy anything, anywhere in the discord window. Tried a different wireless mouse, a corded mouse, different browsers, nadda. Even after firing up my older Windows 10 laptop (opposed to my tower) STILL no luck... SO, after trying Other MULTIPLE Machines, hardware, connections, Operating Systems (windows xp, 7, 8, 10) Do Not tell me its MY (all of our) Account or (All of our) My Machines causing the issue.

    wtf did you do discord?! For the love of Christ, even the BOTS arent taking commands properly or at all either!!!!

  • HillDragon

    I've found that if you highlight a word before right clicking you can get around the bug for now.

    this only partially works for the 'menu' key on the keyboard as it will open the context menu but it will be for the first word in the text box (which is not helpful if you're correcting spelling.)

    I use the browser version.

  • Jarizle88

    I'm having same problem and only fix I found is to reopen site.

  • Neil—Groovy_Jedi

    Came here looking for a fix and its sort of comforting to see i'm not alone. A work around I've realized is to type something just gibberish and right click on the text it works and you can copy links as usual. I also heard search function is giving trouble. The API issues aren't fully resolved yet so i'd give them some time. I use discord web btw.  

  • Sylvenmyst

    please fix this, discord. I also have this problem in Firefox web interface. I use right click for spell check. There is a work around for now, but it is going to get old fast.

    HillDragon, I have figured out that your right click work around works if you highlight only the red underlined misspelled word. Then it brings up the spelling suggestions for that word.

  • medievil

    just updating this has been fixed as of today....

  • ASSassin{FR}

    same for me since few weeks (discord browser in france..)

  • Silver

    This issue has come back up in version 0.0.14, running the Linux desktop version and the current revision is Stable 80496 (2ea5fec).

  • Seldo

    Fixed huh?  Yeah I've been having this issue for more than a year through 2020-2021.  Win 10, updated, no other issues, but discord will not right-click close.  What a coincidence its the only way to close discord without having to alt + f4 or task manager force close it.  I don't think its a bug as much as a design flaw, after this much time.


Please sign in to leave a comment.