Problem with "push to talk" and new OS Catalina IMac

Comments

15 comments

  • Xavier Ryan

    I had the same issue even after giving access to Discord in Accessibility. I then noticed that there was in Input monitoring option underneath Accessibility that I also had to gave Discord access to. Once I did this, it started to work.

    9
    Comment actions Permalink
  • Xavier Ryan

    On my computer, I went to:
    - System Preferences
    - Input Monitoring (located under accessibility. It has a keyboard symbol)
    - Plus Arrow and add discord

    Hopefully that makes sense

    2
    Comment actions Permalink
  • lokeewna

    It's under Security&Privacy now

    2
    Comment actions Permalink
  • Chokk

    I also have this problem.  The Discord App will not take keybinds when I attempt to record them.

     

    Please Help

    1
    Comment actions Permalink
  • Twistedr Complexity Limit>

    @xavier ryan can you explain what you mean by input monitoring option?

    1
    Comment actions Permalink
  • The Forgetful DM

    Hey I'm running into the exact same issue. Without luck I haven't been able to solve it. This is the closest I've gotten so far. 

    https://support.discordapp.com/hc/en-us/articles/360035130231--Known-Issues-Discord-on-macOS-Catalina

    0
    Comment actions Permalink
  • icybl00d

    @Xavier Ryan 

     

    This solved my problem, thanks man!

    0
    Comment actions Permalink
  • ingy_bingy

    Thank you so much! Finally got it fixed 

    0
    Comment actions Permalink
  • Twizmate

    Xavier, was the "Discord option" just there when you clicked "Input Monitoring"? I see that section, but there's nothing in that section and no way to add an app. I'm on an older MacBook Pro though (Mid 2012), so I don't know if that's the issue or not.

     

    0
    Comment actions Permalink
  • almostadrian

    They moved the setting from "Input Monitoring" to "accessibility"
    After you activated that you have to restart discord ... now it works :)

    0
    Comment actions Permalink
  • ggk1

    @twizmate- just check the box that's next to discord. This was the suggestion that fixed it for me. Thanks Xavier

    0
    Comment actions Permalink
  • Erwann

    Arg. I don't have it on my side: 

    I tried to reinstall Discord, but it's still not showing.

    No PTT for me :( 

    0
    Comment actions Permalink
  • Erwann

    And ... it's working for me this morning after a Discord update ! 

    (but still nothing in Input monitoring) 

    0
    Comment actions Permalink
  • jakbo

    I also have nothing under input monitoring, and it's not working.

    0
    Comment actions Permalink
  • Adenaël

    the function was moved to "Accessibility" Go to preferences > security & privacy > privacy > Accessibility and there, click on discord. It should work.

    0
    Comment actions Permalink

Please sign in to leave a comment.