Make Discord ACTUALLY start minimized when it's supposed to



  • SadFrogMemer

    1 year later, this is still an issue that never got resolved... Should I make a new thread to try to boost awareness?

  • Reynard D. Fox


  • klyde

    Still not fixed

  • Ozama

    Still not fixed in 2022 bruh

  • .floatingsunfish

    This is very annoying. I'm thinking of uninstalling the Windows app just because of this issue.

    Please fix it! It should be relatively simple!

  • J4UNE

    Exactly! This is annoying. When I turn on my computer in a hurry, while trying to get my work done, a gray screen appears for a few seconds.

  • Rofii

    2 years and it's still like this. The only solution is to disable starting discord with windows, and only launch it when you need to use it. You'd think they would want users to have it open as much as possible.

  • Danyil

    I have a workaround solution for windows without any pop-ups.
    Press Win+R. Write shell:startup in prompt.
    Create a new shortcut there. Place path to Discord.exe with --start-minimized parameter.
    Resulted string should look like this
    C:\Users\Danyil\AppData\Local\Discord\app-1.0.9012\Discord.exe  --start-minimized
    (remember to change Username and check your app version)
    As last step disable auto start in discord app to remove default entry.
    Congrats! You no longer have to wait many years for Discord devs to fix this.
    This method probably disables auto-update on launch, which I find to be behavior I like more. Just make sure to press green update button from time to time if you see it in your discord app.

  • Particle

    Thanks for the tip Danyil

    Unfortunately it doesn't seem to work for me. I made a shortcut to Discord.exe and added the --start-minimized parameter, but it still opens a fullscreen blank window for a few seconds when I launch it :(

    I even tried the Run: Minimized option in the shortcut properties but that doesn't seem to accomplish anything either.


Please sign in to leave a comment.