Crashing upon joining voice channels

Comments

46 comments

  • Wilbert

    Turning off "advanced voice activity" fixed it for me.

    2
  • kenward

    @UnitedPongs This works for me as well. Is there a formal place for us to create a ticket or something so Discord can see this and put out a patch?

    0
  • iHasNuFriendz

    I saw that if you turn off Advanced Voice Activity, you wouldn't crash anymore upon joining a voice channel. However, mine is locked for some reason. Does anyone have any idea how to unlock it?

    1
  • razzarctic

    @iHasNuFriendz i was having the same problem. under input sensitivity you have to turn off “automatically determine input sensitivity” and that will allow you to turn off advanced voice activity. once it is off you can turn off auto input sensitivity again and it won’t change the advanced voice activity

    2
  • iHasNuFriendz

    @razzarctic that worked. Thank you!

    0
  • Juhthreef

    I like discord but this is getting stupid. Up until yesterday I was able to turn off Advanced Voice Activity on my mac and it worked fine but when I opened discord last night I'm back to crashing again which is infuriating. I also noticed that Advanced voice activity for some odd reason was stuck on, and even enabling automatic input sensitivity and then disabling advanced voice activity and re disabling automatic input sensitivity puts me back into a crashing state.

    0
  • djevvy

    I'm on a 2008 iMac, and it worked!

    0
  • JoStanley

    It worked for me since I turned off the "advance voice activity". I have a 2010 MacBook Air (MacOS 10.13.6) thank you for the tip. 

    0
  • TransilvanianMonster

    Thank you @UnitedPongs ! I went to Settings-> Voice and Video -> Advanced Voice Activity - Switch Off. Completely solved the problem.

    0
  • Ghsotwolf117

    HOLY $#@% turning off "advance voice activity" actually works! Need to tell this to the other thread that is have the same problems (if it works for them).

    0
  • islud

    turning off "advance voice activity" worked for me, but the same problem appears when trying to join a shared screen, does anyone also know how to fix this problem?

    0
  • ddyer

    nixing "advance voice activity" fixed this for me, too, but I'm alarmed by how old this thread is.  Does discord fix their apps?

     

    0
  • Neil Strickland

    Thank you to everybody who contributed to figuring this out! Much appreciated.

    0
  • kenward

    Also for any hackintoshers out there running AMD hardware, I was having trouble joining streams and stuff as well. Running discord with `MKL_DEBUG_CPU_TYPE=5` helped with that. Seems to be an intel library only and creating issues on AMD hardware. I just added this alias to my terminal:

    alias discord="MKL_DEBUG_CPU_TYPE=5 /Applications/Discord.app/Contents/MacOS/Discord &"

    0
  • davigamer987

    I solved the issue on my Macos Catalina Hackintosh By disabling Krisp And Advanced voice Activity

    1
  • MalexMusic

    I fixed it on my Ryzen Based Hackintosh by enabling the "automatically detect input sensitivity" setting, and disabling "Advanced Voice Activity"

    Big Sur 11.2.2
    Ryzen 2600x

    0

Please sign in to leave a comment.