Set default API version to v9 or above

Comments

3 comments

  • donovan_dmc

    The default is kept at v6 to be backwards compatible

    Once v6 is completely decommissioned (which is happening right now, and has been for a bit) it'll likely be bumped to v8

    You should be providing an api version either way, so you can control exactly what version you're using

    (in my personal opinion, apis should not allow unversioned access to avoid issues with changing defaults)

    1
  • asciidude

    Ahh, understandable.

    Also, I completely agree with the unversioned access statement, I've always found it a bit.. stupid.. that they did that.

    0
  • donovan_dmc

    This either comes from coddling devs who can't be bothered to supply a version, or a naieve though that new api versions wouldn't be needed

    I myself have done this with an api, though when I did a V2 I completely threw away unversioned access eventually

    0

Please sign in to leave a comment.