Discord overlap on multi-monitor.

Commentaires

18 commentaires

  • !BotTester

    This has been a problem for over 3 years as far as I know.


    The only way to fix it is to disable hardware acceleration in appearence

    -2
  • Sadly this does nothing for me. Still the same thing... I have to manually resize the window pretty much every time i open it because i cant see if a server has new messages (the white indicator disappears in the overlap)

    2
  • cyberhawk

    I disabled hardware acceleration, but it still remains for me.

    2
  • Ailemia

    In the past, disabling hardware acceleration worked. Then i had to switch to Windows 7 compatibility due to issue with CUE. At one point i was too annoyed and ditched CUE so went back to normal discord, at which point the problem was back but this time, hardware acceleration does not fix it anymore.

     

    The only fix i have right now is to use Borderless Gaming (great tool for any game really) and force discord in borderless (don't worry about borderless, you will still have windows taskbar, it's not a fullscreen borderless strangely).

     

    After using borderless gaming you have to switch full screen on then off and it will remove the extra pixels on your other screen.

     

    HF

    2
  • Asha7494

    If you run discord in windows 7 compatibility mode (right click the exe  > properties > compatibility) then it fixes

    4
  • zenvoid

    Disabling hardware acceleration worked for me and it doesn't have a huge impact on performance since I have a good cpu

    0
  • David 💞

    I fixed it by Right-clicking discord, going to "Properties" clicking "Compatibility" and checkmark in the box where it says "Disable full screen optimisations"

    0
  • Ailemia

    Tried again today

    Disabling hardware acceleration does NOT fix it

    Disabling fullscreen optimisations does NOT fix it

     

    So i'm still gonna go with Borderless Gaming to fix it (doesn't matter if hardware accel is on or not so that's good)

    0
  • David 💞

    Ailemia What kind of monitors/specs do you have? and what exactly is the problem you experience?

    0
  • David 💞

    Rabid and you, what are your monitors/specs?

    0
  • eggo mcreggo

    I'm having the same problem, and it's kind of annoying because I have 3 monitors horizontally and I like to put Discord on my far right one. The part of Discord it hides are the little white dots beside the servers that tell me if there is any unread notifications behind whatever I have displaying on my middle monitor. The right one is a 1080p 24" and my middle one is a 4K 32".

    1
  • SamuelAdams

    I'm having this issue too. I found a reddit thread for almost 5 years ago about this issue, can't believe it hasn't been fixed by the discord team yet.

    1
  • Rabid

    David 💞

    Any reason you want to know? Are you a dev?

    Sorry only seen your comment now as I just got a notification email that SamuelAdams above had commented.

    Seems like many people are having this issue for a long time on different setups.

    Appreciate the advice everyone regarding potential fixes. There's only one fix though and that is Discords devs code their program to scale correctly.

    Literally the only app I use that does this.

    I'm just running it not full screen. It's annoying but I can live with that. Also stops Discord from blocking me dragging windows from one monitor to the other as it does when fullscreen. Again something seemingly exclusive to Discord.

    Great app. looks streamlined but it's obviously a bit jank under the hood. But hey cannot complain when I aint paying for it I guess. (well not paying in obvious ways that is anyway. 😉)

    0
  • SimpForAshAndJager

    Haven't had an issue until recently, looks like some peeps r coming along with me.

    0
  • konwave

    running in compatibility mode for windows 7 fixes it perfectly for me.

    1
  • Misanthropy

    Win7 compatibility mode fixes it for me, too.

    For the Win10 folks: do Start, Discord, Open file location. Right click the shortcut, properties. Compatibility tab. Hit the checkbox for compatibility mode, set it to Windows 7.

    Worked like a charm here. The other resolutions listed didn't hold up for me. I'm also one of those tri-monitor misfits who prefers Discord on the far right screen. 

    1
  • zombiewizard45

    Windows 7 compatibility mode did bring the edges back, but now there are small bars on all sides of the Discord window. Not sure if this is better. FWIW it's on my main 4K monitor

    0
  • SamuelAdams

    Having the same problem as zombiewizard, but my monitor isn't 4k. In win7 compatibility you also can't stream/screen share with sound

    0

Vous devez vous connecter pour laisser un commentaire.