Left clicking the tray icon in Discord 0.0.8 for Linux



  • Anton Demanoff

    Yeah, it's really annoying to click Open Discord every time. It will be cool to restore previous behavior or at least add option to Settings (if it's a feature not a bug).

    Linux Mint 19.1, Gnome 3.28, Discord 0.0.8

  • Melfice

    Still an issue after today's update

  • darkpenguin

    Still a very annoying issue, or rather, regression. For some reason, it is only present on Linux (I have Debian Jessie and MATE).

  • Natetronn

    10 months after last post...left clicking the Discord App icon in the system tray on Linux (Manjaro KDE) does nothing. One has to right click and Open Discord to launch the app from the Top Secret Control Panel. Like everyone, I like Top Secrets but, I'll take good usability and user experience any day of the week if Top Secret is going to be like this.

  • Fiwa

    bumping, this is just so dumb. clicking / double clicking the tray icon should open discord and not showing the menu on right clic.

  • 4Bidden

    very true as this is extremely annoying, please fix it and make our linux experience comfortable :)

  • Fiwa

    might be related to the flatpak, not sure who maintain this thing.

  • HolyBlackCat

    Can we get this fixed? Telegram also had this problem, but it was fixed recently. It would be nice if Discord did it too...

  • Progcppk


  • Fiwa

    fix tray icon pls

  • darkpenguin

    Recently, a strangest thing has happened: I saw it work on another PC! I think it also worked on the Debian Buster LiveCD. However, it still does not work on any f my PCs, even after completely reinstalling Discord (latest version).

    The weirdest thing is that this "another PC" was actually a copy of my own "not working" system! I've added another user, but I've configured that new user the same way as my own. So, seems like it actually works for some people - which is why this bug is apparently treated as "works for me".

  • MartinPL

    If someone need workaround on GNOME 3.36:

  • gaming

    still a thing on 0.0.10. oddly it was working for a while but not anymore

  • TheHaricover



    I have the same issue (left click = right click, system tray icon) on Manjaro :

    "Stable 63822 (1c88f92)

    Host 0.0.10

    Linux 64-Bit (5.7.9-1-MANJARO)"

    Steam have EXACTLY the same issue.

    I searched a little and it appears that Discord, Steam and some other apps are using "libappindicator" and this library doesn't support the system tray icons.

    Isn't there a way to use another library ? Or implement a workaround ?

    For now I'll try to open Discord with a keyboard shortcut.

    PS : In the same time, can't we also have the voice indicator in the system tray like in windows ?

  • waltergallegog

    Was anyone able to solve this issue?

    I found this workaround: https://bodhilinux.boards.net/thread/896/make-discord-open-click-system

    sudo touch /usr/share/discord/libappindicator3.so
    sudo touch /usr/share/discord/libappindicator3.so.1

    which works for me (I'm using KDE),

    but..it makes the discord tray icon blurry (again).

    When I first installed discord, the tray icon was blurry, which I solved following: https://wiki.archlinux.org/title/KDE#Blurry_icons_in_system_tray.

    sudo apt install libappindicator3-1

    So at least for me:

    • If I want the left click to work, I have to "mask" libappindicator3 for discord by touching those two empty files.
    • If I want the pretty tray icon, I have to "unmask" libappindicator3 by removing those two files.