Discord won't open on Linux when an update is available


88 opmerkingen

  • DoorStuck

    Experiencing the same issue with snap package 0.0.12 in Ubuntu 20.04.1 as of 2020-09-10 as well.

    Issue resolved, update now available.

  • Skalli

    On Manjaro the new Update was pushed. This time it was luckily fast again. But last time it took a few days.

    Still this situation sucks. Wish it was acknowledged at least.

  • Whodiduexpect

    0.0.12 is still not in the Arch repos and I can't use Discord at all. It's completely unacceptable to force people to use a version not yet available on their platform. I'm rethinking using Discord at all if they decide to make arbitrary decisions that completely prevent you from using the service. Even Skype and Teamspeak actually work reliably, as well as not actively making user-hostile decisions the way Discord does.

  • snipeytje

    yes at least discord canary is already updated, so you can use that. But the lack of grace period and the lack of indication in the UI whether the available update requires a client update or is just a refresh makes discord much less usuable

  • taktician

    I'm on Manjaro - still no update. I've synced packages, nada.

    I'm trying to be polite - but from a software engineer's perspective, this is pretty bad. 

    Please give us an ETA or some indication that you're aware of this problem - or just tell us it's not a priority so we can find an alternative. Some of us use this for work too - but not for much longer.

  • antiftw

    Same problem for a Ubuntu user, Snap package manager says Discord is up to date, but it wont run because I need a newer version.

    So am I supposed to uninstall and reinstall using the deb file, to afterwards delete it again and install it once the package manager recognizes that there is an update available?

    It seems like an unnecessary amount of trouble to go through for a VoIP-application. If it was some kind of security update for my OS I could at least understand the reasoning, I fail to see the logic in doing this.

    And I agree with taktician, if this is not fixed, I will be forced to switch to a different solution, because this is not reliable software, I am not going to spend 30 minutes of hassle each time Discord has an update.

    Edit, 1 day later:

    Wanted to say that I didn't even have to update/install anything, but Discord "automagically" updated once I launched it this afternoon. So now they need to just make sure that the moment of auto-updating is equal to the moment they start requiring the newest version, and we're good :)

    Edit 15/9/2020:

    I had opened a separate thread since I didnt know if this one was still active:


    And I actually got response from a Discord employee saying something to the extent of: We do not officially support Linux, thats why there might be problems, but if we get enough upvotes on this post their developers might look at it.

    Just wanted to let you all know.

    Kind regards,

  • cesarizu

    Same here with openSUSE tumbleweed, updates might not come for days and one couldn't use the app as intended.

  • shon

    I've hit the same things for the second time in 6 months. I won't be held hostage in this way, and I have the power to choose what platforms I communicate on. So, personally, until this user-hostile behavior is fixed, I'll simply be informing contacts that I refuse to use discord, and ask them to join me on less anti-user platforms.

  • JLE79

    I found this thread because this just happened to me.  

    Imo, threatening to leave discord won't do any good.  
    Pretty sure the number of linux users are very very small.  

  • ag/dot

    -self moderated-

  • /PanPernicek/

    yeah again with 0.0.13

  • Richard Michael Coo

    Happened to me as well.  It's like they're saying the 0.0.12 desktop client is incompatible with its 0.0.13 backend.

  • BlufaminPC

    Canceled my subscription just because of this...


    Here is a quick fix:

    sudo sed -i 's/12/13/' /opt/discord/resources/build_info.json
    You might want to check your installation path!
    To find your path:
    sudo find / -wholename '*discord*build_info.json'


  • Minion3665

    Same issue with 0.0.13 on arch, might make a discord-matrix bridge so I don't have to deal with this. At the very least I'm going to email support and see if there's a workaround they could suggest.

    Wish me luck.

  • antiftw

    Hi Minion3665,

    When I first encountered this error I contacted support and if I understood correctly the Discord package offered through SNAP package manager are not official Discord package and as such not maintained or officially supported by Discord.

    The only official Linux builds are offered at http://discord.com/downloads 

    So contacting them with regard to any other packages than offered on the link above will most likely be a waste of time.

    Secondly, I just rebooted to Linux after I read your post and strange enough Discord updated here without any problems (this is 2-3 minutes ago) and has successfully started without issues. I do use the standard Ubuntu distribution though (Ubuntu 20.04.1 LTS 5.4.0-56-generic)

    If you are interested you can read back some of this communication in https://support.discord.com/hc/nl/requests/8960585?page=1 
    The conversation does switch to Dutch at some point so if you have any questions about that thread, I don't mind translating it.

  • Minion3665

    Hi antiftw,

    Glad you got it working. I use arch (5.9.10-zen1-1-zen) myself and the package manager is pacman not apt, so unfortunately mine hasn't updated yet. I do doubt that the support will be useful, but I'm still going to try just in case they have any good ideas.

  • antiftw

    Hi Minion3665,

    I read back the other post and noticed it was the SNAP package manager, and I have double checked and APT indeed doesn't have the Discord package (at least not without adding any additional repositories). I have corrected this in my original message.

    I have quickly googled and it seems that SNAP is also available on Arch (https://snapcraft.io/install/snap-store/arch). I don't know if this might be a solution for you?

    If not contacting Discord might clarify things further for your situation. In my opinion the first answer was rather quickly but before I got a message back from the developers (they were kind enough to pass it on) it took a few weeks. That's also the reason I suggest the SNAP method, because this might help you in getting Discord to run again faster.

    Good luck in getting it to work again.

  • BerlinOP

    This happens to me now, I had Discord installed on my arch Linux machine. Today I tried to open discord but it showed a msg that you need to either download the .deb package or the tar.gz package or "I'll figure it out".
    I downloaded the tar.gz package but when I try to install it using Pacman -U discord-0.013. it says that Pacman could not find all the required packages.
    when I tried installing using yay, it installed the discord-0.0.12.

    What to do?

  • antiftw


    Have you tried using the SNAP package manager?

    Snap on Arch https://snapcraft.io/install/snap-store/arch

    Discord through Snap https://snapcraft.io/discord

  • Tidy Dave

    Surely it's possible to find some middle ground here?

    Would a grace period pop-up on startup showing the number of days left before locking the client out be a better solution than the one currently in place?

    It's a real pain in the arse to be locked out without warning is all (for every single update).

  • antiftw

    Tidy Dave

    Like I mentioned, all packages that are NOT downloaded/installed from http://discord.com/downloads are not supported by Discord, so for any changes on this we would need to contact the actual maintainers of those packages. Since I haven't had any more problems since I first encountered this, I haven't looked into who those people would actually be.

  • Phitherek_

    Just a quick tip for any Arch-based users.

    Use ABS.

    Download the PKGBUILD through asp tool, change version, change the checksums to SKIP and you're good to go.

    I still agree with the grace period request.

  • NightFantom

    Discord just broke their debian signing or something and now I can't use the old version, and can't install the update because it's unsigned..

  • Tidy Dave


    I realise that downstream packages within the various flavours of Linux cannot be expected to be supported - what I'm talking about is the server-side decision to disallow any clients with an old version to connect to the central Discord servers - suddenly and without a grace-period.

    Unless you're saying that the issue is really client-side - which while possible, is unlikely. Is there any information out there that would determine the cause of this issue?

    EDIT: hang on, I think I may have misread your post - why wouldn't they support packages hosted on their own website? I'm assuming that's a typo as I think we're on the same page based on reading your last few posts. It seems as though the links you posted to your conversation are gone now though...

  • J_tech0

    If you're on Manjaro, it looks like 0.0.13 is available on the official repos already. If you're on the official Arch repo, they're still on 0.0.12, but Snap and Flatpak are already up-to-date instead (bear in mind they haven't always been this fast to keep up, though)

    I've said it before and I'll say it again. While Discord doesn't have any obligation to support anything other than their own .deb and .tar.gz downloads, it would be greatly appreciated if they at least built in a grace period to allow users to continue using the old client until the new one is available in their preferred package manager. Just let the "I'll figure it out" option allow us to use the old version for a bit longer!

    The "I'll figure it out" option in the pop-up also shows that they are clearly aware that loads of people install Discord in other ways than their official downloads, and knowingly blocking those users out is honestly just user-toxic.
    The fact that you can change the version number in build_info.json to bypass the version check and still be able to send/receive messages is proof that there's no functional reason why the old client couldn't be used on the new backend for just a couple more days...

  • antiftw


    I am a bit confused how Discord would want to "support" a package they have no control over? Since the non-official packages are not maintained by Discord, it seems impossible for them to alter code over which they have no control? Or am I missing something?

    Tidy Dave

    This is what I understood from my last communication with them, that they have no control over these implementations. And indeed that was a typo. The only official Discord supported packages are hosted on http://discord.com/downloads . All other packages are not officially supported/maintained by Discord, but by third parties. The other post I had linked to was https://support.discord.com/hc/nl/requests/8960585?page=1

    To both: I have not pursued this further because I have had no problems since the first time I encountered this. I had also pointed out the same reasoning as J_Tech, saying it would be more logical to allow some kind of grace period, given that it was not a critical security update.

    Their literal response was:

    "Bedankt voor je geduld. Ik heb een reactie ontvangen van het team. De Linux-installatiebestanden op de pagina http://discord.com/downloads zijn de enige officiële builds die van ons afkomstig zijn. Als dit niet de build is die je gebruikt, is het geen officiële build en wordt het niet door ons ondersteund."

    Translated to English:

    "Thanks for your patience. I have received a response from the team. The Linux-installationfiles at the page http://discord.com/downloads are the only official builds that originate from us. If this is not the build that you use, it is not an official build, and is not supported by us."

    A thing I do remember them saying at some point in this communication, which was a bit confusing to me, was:

    "Mocht je je echt storen aan het feit dat gebruikers worden gevraagd om een update te doen, dan kun je proberen te kijken of je communitypost genoeg upvotes krijgt. Je post wordt dan eerder bekeken door onze ontwikkelaars die wellicht hier iets aan kunnen doen."


    "If you are really annoyed by the fact that users are being asked to do an update, you could try and let the communitypost get enough upvotes. Your post will then be viewed by the developers more quickly and they MIGHT be able to do something here."

    I did ask a followup question about this but got no real response other than the first bit I copy pasted, stating that the only official Discord builds were the ones offered on the link http://discord.com/downloads .

    So it might help contacting them again, stating that you are having problems, again. I doubt it, and it seems more logical to first contact the maintainers of the non-official packages so that we know what they have to say about this problem. An extra benefit of this would be that we would have more specific information when returning to the Discord developers again with this problem.


  • Tidy Dave


    Thanks for the translations. Yeah it makes total sense why they wouldn't care about the packages they don't maintain.

    I think we can all agree that the optimal solution here for everyone would be a grace period. Since this is likely something only enforceable server-side I very much doubt there is anything downstream package maintainers can do to about it.

    I have upvoted this post to show my support and asked Discord support to have a look at this thread.

    Out of interest, do you know if the .deb & tar.gz maintained by Discord auto-update (can't remember if you said you use them or flatpak or whatever)?

  • antiftw

    Tidy Dave

    No problem.

    Indeed, that would seem the best solution, and I also agree that it does sound logical that this grace period would be a server-side problem. However since we are not certain of this, it might be smarter for us to first contact the maintainers of these alternative packages so that we actually know what's going on before going back to Discord with this issue.

    I wouldn't know if these .deb/.tar.gz auto update. It does seem likely since the update functionality of all the Discord distributions I use seems to be included in the package themselves. However I cannot say this with certainty because I have not tried them out, as my (Snap installed) Discord updated itsself before I tried switching to the official packages.

  • fghsgh

    Also had this issue. Locking out old versions for no reason whatsoever is not the way they should be treating their users. Commenting here to show I also find this a serious issue. It's not hard to fix either.

  • Lex

    This is a feedback thread; effectively an issue report for the user-toxic behavior Discord has with its Linux versions.  It's not an individual support request looking for workarounds.  Let's continue to treat this as a feedback thread and rally for Discord to change its Linux version to not disable all functionality when there's an update available.  No other major software does this, and it's a terrible precedent to set.


U moet u aanmelden om een opmerking te plaatsen.