headset cutting out


5 opmerkingen

  • Youju

    Hello, does Discord still cutting out your Voice?
    I had the same problem but i found the solution.
    I made a video, because this is really anoying:

  • LiamDooD

    Using Steel series Arctic 1 Wireless headset.

    ~180mbps up. 20 mbps down. 14ms

    Server region Europe

    I'm also having a similar issue. During the mic testing in the voice and video settings, if I hold a continuous sound. for example "Baaaaaaaaaaaaaaaa" or "Moooooooooooooooooo" what I get returned cuts out cyclically per couple of seconds, I can only really describe it as like a square wave, it's either on or off, not  crazy distortion. This is also heard from the other users in the server when I'm speaking normally, which leads to much confusion as I can hear the other users fine.

    I have recently changed from another headset, which also had the same issue using Discord. Using Sound recorder gives me flawless capture from the mic and the other evening we had to resort to Facebook voice chat whilst gaming which (surprisingly) worked rather well, with no loss in recording. So I'm pretty sure the hardware and network side my end is fine.

    Google-Fu has sent me in a few directions to "fix" my issue, IE. Changing server region. Toggling Quality of service high packet priority, Echo cancellation (although unable due to headset being certified), input sensitivity options. Re-installing Discord etc to no avail.

    If using the headset through my Phone and the android app, I don't seem to get the issue, which is very strange.

    At a bit of a loss really, so if anyone has any other ideas I'd love to hear them!

  • Youju


    Did you watch the Video?

    Did you turn of "Echo Cancelation"?

  • ZeTT

    disable echo Cancellation.. if your mic is certifed and you can't change it. put your mic to default instead of the certifed mic and you should be able to change it. Remember to set your default mic in windows.

  • PuanJablo

    LiamDooD u prob figured it out by now, but regardless, I had the same exact issue as you, and what fixed it for me was unplugging my Oculus headset (even though it wasn't activated{???} I even disabled it in the Windows settings but that did nothing. unplugging was the only way) then setting my discord mic to default (i also have a "certified" artic headset) and disabling echo and noise reduction.

    I hope this helps


U moet u aanmelden om een opmerking te plaatsen.