Option to stop Krisp Noise suppression turning off automatically

Kommentarer

56 kommentarer

  • AyOhEe

    I should add, this also affects me in that my friends *do* turn on KNS, but it automatically turns off and I have constant background noise, which I cannot avoid without deafening, meaning I can't hear my friends.

    2
  • SimonSaizGo

    This is a false positive problem.
    I have 5 CPU cores doing nothing but krisp keeps turning off after a minute or less.

    It works really well when it's on; I just need a way to tell it to ignore it's assessment of the system performance counters and stay on unless I explicitly turn it off.

    8
  • Abide

    I have the exact same problem.  8 cores running at 2% noise suppression spam turns off.  For some reason my compressor mic doesn't work in discord without this option turned on.

    5
  • Tamrial

    Same problem here. 12 cores, never high usage, still turns off automatically.

    3
  • Treefiddy

    Same issue. 8-core 10700K, idle, turns off randomly. CPU isn't even spiking. Works nice when Discord allows me to use it. It's the only reliable thing that eliminates background noise for me and even boosts voice quality.

    2
  • AyOhEe

    this appears to be a different problem to what i was having but the solution remains the same. i was actually having cpu usage problems, but still wish to have crisp remain on.

     

    also, still crickets from discord 2 months later? what else should i expect i guess?

    1
  • sjcl

    Same issue. In addition to CPU usage, GPU usage appears to be affected.

    0
  • Drevneus

    I also recently discovered this problem with myself and friends. This is a great technology and works for modern mechanical keyboards and usually not very good microphones. But unfortunately, for some reason, it turns itself off. Fix please!

    1
  • Abide

    Seems to not be an issue when using voice activated, but that could just be random luck.  Another work around is if you open up Settings > Voice & Video and leave discord on this page it won't turn off.  Not a fix, but a work around for now at least.

    1
  • lXndr

    Same here, it turns off, but CPU is idling.
    Maybe its because power saving underclocking, it takes some time until my CPU jumps from 1,3ghz back to 4ghz, in this time CPU has 100% and it triggers Krisp to deactivate. In this case: adding a delay before switshing it off.
    Sry for my bad english.

    0
  • Drevneus

    No, I never found a dependency. That with a fixed frequency, that with an auto-boost, the pc is idle or loaded. It just turns off at some point...

    0
  • CANADIAN PIG

    Same issue here. There should be an option to disable performance based disabling even if it is a feature. My processor appears to be running high because I have an AMD designed to run at 99-100% usage (not real usage, just the throttling) and Krisp thinks my PC is dying even though actual usage is sub 50%. A workaround it to leave you Discord window open and enable it and leave the menu open, but that is silly. 

    2
  • Yen

    Same problem on my android phone and ipad mini. I have to check if it is off every time I use it. It's really annoying for me. Please fix it, thanks.

    1
  • itsC0mrade

    Up, need add it

    1
  • onemantooo

    up

    1
  • ronan36880

    same here

    1
  • Pedro Victor

    same here :(

    I hope they fix it x.x

    1
  • AC

    Bump

    1
  • GriffinMeister

    same here, please fix!

    0
  • Metzelmann

    Same, please add the toggle the OP suggested

    0
  • rivmi ♡

    Bump!

    -1
  • Dino

    up

    0
  • MrRain

    Up!

    0
  • サエ

    Up

    0
  • itsC0mrade

    up

    0
  • Andargor

    Still an issue, very annoying.

    0
  • grisha

    Is there a technical reason this feature can't be fixed or completely removed? It annoys most people...

    0
  • Arma2.0

    bump

     

    0
  • Efreeti

    Bump

    0
  • CARGOJEANS

    bump please for the love of god

    1

Du måste logga in om du vill lämna en kommentar.