Keep Discord mobile from hogging the audio stream.

Kommentarer

149 kommentarer

  • I have Anxiety

    OOF

    -3
  • Light

    I fixed it. Put the audio on 'Call Mode'. (Discord settings). Then, turn off 'Automatically determine input sensitivity' and turn the sensitivity slider all the way to the left. Done. (Don't forget to restart the app for the Call Mode to take affect.)

    1
  • De Daniel

    The opensl es doesn't work for me...
    But with bluetooth earphone, disconnect then connect it while in a voice channel manage to change the audio mode from call to regular/normal mode

    0
  • Valdas

    Its been freaking so long this has been posted and still nothing... why does this have little bumps too...

    10
  • aka. ♡

    i had a support ticket open about the issue that they left hanging for months without trying to fix the problem and then randomly closed it xDDF

    8
  • Sylvenmyst

    Discord mac app as well. It mutes my game sound and there is no way to change it with mac settings that I've found.

    0
  • Dima

    Unfortunately there is nothing discord could do.
    When using Bluetooth headphone the phone will automatically switch to the "Hands Free profile".
    Problem is that it only supports the "bad quality" audio.
    To have good audio your phone/device and your headset need to support more advanced codecs. More info here -> https://smallbusiness.chron.com/differences-between-handsfree-headset-profile-70351.html

    -1
  • Praça Psicodélica

    Anyone have solution? i need fix this for my members :)
    We us electronic music community, but not have a good sound to my cell phone members

    4
  • Abandoned account

    Audio on mobile seems to be mono only, and that audio quality degrading thing is caused by a noise suppression filter applied by the audio drivers on some Android phones, I've mostly seen it happen on Samsung phones and the only way around it (for me at least) was by installing a custom ROM, however, changing to call mode can also fix the issue sometimes. LineageOS, for example, does not have the filter and works perfectly (although still in mono).

    0
  • Bngooz

    In settings > Voice & Video > "scroll to bottom" Audio mode change it to the other option (for me call mode)
    If not try changing the low-latency hardware accelertatios (for me Force OpenSL ES)

    0
  • chanchiwawi

    my solution was to use ts3 for mobile XD

    2
  • xiaopangju

    I have same feedback

    1
  • Heidi

    I have this issue too. It's so annoying. Call mode almost fixes the whole issue for me as the audio is so clear yet I'm suddenly extremely quiet. I know it's an android thing so maybe that's why discord hasn't done anything?? However I can't help but feel it's like they don't give a crap about their community sometimes, I wish there was a solution.. :/

    0
  • Denamantez

    discord also hogging audio stream from other APO in windows too. especially dolby atmos

    0
  • mew

    My audio just messes up after receiving phone calls. If I receive a phone call during discord call, then either the others will hear their voice echo through my end, or just can't hear me. Rejoining the call, or force stop the app doesn't fix it. The only thing that works is to restart the phone. I've played around the setting, I've disconnect VC first before receiving or making phone calls. Nothing works. I've not always had this issue on this phone. Just started a few months ago. And now ppl even complain they can hear me typing msgs. I'm beyond annoyed.

    0
  • jephph

    I found a fix set to call mode enter call and switch output to phone . This worked for me after having to listen static filled music for months and I tot that was normal

    -6
  • Hyperion

    I don't know why the comments saying call mode fixed their problem are so down voted, but that- then restarting my app fixed it for me...

    4
  • JustDewIt ⚡

    I think some of you are not understanding the what the end result should be. We should have full HD audio which would be controlled with the Media volume slider. Like if you don't wish to speak, or want to listen to music/watch a stream on mobile. The only reason *why we can't do that*, is so that Discord has access to the mic, which needs to implement a background noise cancelation "effect," which stifles the audio output. My inference as to why Discord won't implement an option to let you *disable the mic* is because people will complain they can't speak due to the mic being disabled, or the audio is different/bad with the mic on

    0
  • StrawberryForest

    I'm trying to listen to music with my friends... Is there a way to remove the call move function for bots? I want to listen to music/ videos clearly...

    7
  • DooM™

    To fix discord mobile "call/recording like audio" in voice channel, go to discord setting > voice & video > audio mode > •call mode instead communicaton mode. it fix mine, hope it help yours... 😊

    0
  • Zak1388

    Bro I can't even listen to the audio from my friends stream, let alone anything else. It sucks cuz I don't wanna have to go turn on my computer every time. Please discord fix this

    0
  • 𝐂𝐌𝐄𝐏𝐓𝐛

    Something that works for me is having the 8 ball pool app open, it forces the audio of the call and the media to be clearer as we would expect it to be usually! 

    Only issue is the sound quality goes back to being crappy whenever you close 8 ball pool or switch apps/go to home screen,  however locking the screen when 8 ball is open keeps the sound clear!

    I hope this works for you all, i feel your pain of listening to call centre quality music when using the discord app

    DEVICE USED: Huawei Mediapad T5

    0
  • PabloGod

    Hello guys, you need to sacrifice your microphone if you want good audio quality. The steps that you need to do on Android:

    1) Remove "Microphone" permission on Discord. Settings >Apps>Discord >Permissions

    2) open a Discord channel, then select a voice channel. A popup requesting a permission to use the "microphone" will appear. Please choose "Deny" and "Remember my decision".

    3) Now, each time that you want to enter Discord will stop you. But you can still enter to the voicr channel if you tap to "Enter" a lot of times quickly.

    Like people said before, looks like an Android error, because its the same issue with other apps, maybe the protocol and that thing its hardware. Maybe in the future new phones can handle multiple voice connections at the ssme time, on android we just have voip and audio media, and both cant work at the same time. Enjoy the audio, suffer for not having microphone 😢.

     

    If dont work, disable noise suprresion on Discord app and anything related to microphone. 

    0
  • Caitlin/Hikari

    Please Discord, can you please do something about this?

    I hate not being able to listen to the music bots on my phone because discord just assumes it's a call and switches to phone call audio settings, killing the audio! This shouldn't be so hard to override!

    0
  • Salman7236

    Still not fixed.

    8
  • Nargrimm

    I agree discord should fix this or at least give us the option to choose.

    Nonetheless I found a workaround, open discord in your mobile browser and check the "use desktop version". This will allow you to listen as "media" and not "call" thus enhancing the audio quality.

    Not the best but it's working

    0
  • {STB}Phoenix

    Bluetooth was my problem, I switched to a headset and the problem was gone.

     

    -6
  • h4te || ᴺᴺᴺ ᵍᵃⁿᵍ

    It's not Bluetooth / I have the same issue on my wired headset

    5
  • shruthadevbantwal

    I never knew this problem as I always listened to music on Discord Desktop. Once I switched to mobile and I initially I thought something is wrong with my phone

     

    9
  • Trainwreck3000

    the audio quality sounds fine normally but if i switch it from phone to speaker sound it breajs the sound quality, even switching it back to phone audio sounds crap, but if i leave and rejoin it fixes it but it sets it back from speaker to phone mode if i leave and rejoin which makes it so that i can't listen to anything if i need it to be loud on speaker

    0

Du måste logga in om du vill lämna en kommentar.