Discord Mobile Emoji and/or custom Emoji problem


71 條評論

  • Joey

    I think Robin Bright is right. One of my servers had :Heart:, which is the same as :heart: except capitalization, and I couldn't use it. I just asked them to rename and now it works. ^ ^

  • GlitterToGold

    Suddenly began happening to me as well and I haven't found a fix yet. It's much more aggressive than before. Nothing is wanting to solve it and I just can't use the emoji entirely.
    I tried tinkering with a different one that wasn't working (Named like "heart-4" or something) and it suddenly decided to work after I changed the 4 to a 2. That's not even the emoji name? What about all the ones that don't have a random number for me to change on a whim? I pay $10 a month for emojis, I don't care about the other features, this is kinda infuriating.

  • AmeiLotus

    Just so everyone knows, just rename the emoji and it’ll be fixed. Discord can no longer parse capitalizations so “LUL” can interfere with “lul” my server is fixed now

  • Garries

    got the same issue, and since i am connected to tons of emote servers to be able to use all sort of emotes for my messages, many of the emotes doesn't work on phone, i've found atleast 10-15 of them.


    i did do a ticket for this 2 days ago, but since this is an issue lasting several months (including me till i took a stand against it 2 days ago) i doubt it'll get a response.

  • Gatopelon

    Its still happening to me


  • Natank

    Hm, weird. It's still happening to me and unfortunately renaming emojis doesn't work.

    It's especially annoying when I'm formatting my messages like this:

    <first line of my message>
    <second line of my message><emoji>

    Because it fails every goddamn time. Unless I put a slash at the end of the first line of my message... then it works perfectly fine? Also this ain't an issue with just messages - it's been happening to me whenever I try to ping someone or link a channel. It seems that it affects everything that's not just a plain text.

    Overall it's really annoying and I've been using slashes to deal with it, but I wish it was fixed already

  • MEGARoomba

    I’m having the same issue, I select an emote and I can see it in the text bar but as soon as I send it, it turns into :emote:, ive tried logging out, making a ticket, checking if discord needs to update, everything. It won’t work at all.

    Is discord support even going to respond to this????

  • Naum

    This is affecting paying subscribers significantly. Any kind of response or acknowledgement would be appreciated

  • Garries

    they did respond back to me, its translated through yandex image translator so its bit wonky.

    according to this support at discord, its a known issue and they're trying to find a solution, just don't know when this solution will come.

  • Artoo

    I'm having the issue with capitalization too.
    I choose emoji from the selector and it has with the wrong capitalization and then doesn't work.
    Example: emote :catJam: is seen as :CatJam: in the picker. When I then press send, it doesn't expand. When I manually change the capital c to lowercase, it does expand.

  • Suzu

    Maybe this is a hint: I encounter this problem solely for emotes with names that are shared on several different servers. E.g. :Clap:, :Cry:, :pepecry: etc. Upon giving them a unique name the problem disappears. At least that was the case for me.

  • Artoo

    And with that last comment, the problem becomes clear:
    I have the :justright: emoji on one aerver and :Justright: on another.
    The selector makes it :justright: while the :justright: is in fact renamed to :justright-1:
    So it seems to be a conflict in logic in the picker and the expander.
    As they're different in case, there's no need to rename the :justright: to :justright-1: according to the selector, but the expander does rename it.

  • pikabowser2082

    I am still using Samsung Phone. As of now, I'm still having troubles inputting an emoji and it still shows :text: than showing emoji. Could it be, it can't show more than 1 emote with with the same :text: ?

  • Mothpal

    I've been having this same problem for over a week (android mobile app). I have the lower nitro. It's super annoying tbh, cause it's a couple of emotes that can't be used from different servers and it's expanding to more of the emotes showing up like :example: . My friends aren't having this issue but I'm kinda glad to see I'm not alone in this. Sad to see that this problem hasn't been fixed for most of us.

  • ᴀᴠᴀ ɪꜱ ᴇ ᴛʜᴇ ᴇ

    I tried using an emoji and it didnt work because the emoji had the same name as other emojis, so I named it stars_stars instead of just stars, but I'm not sure if doing that is something to solve it

  • macintoshiba

    Yup, sure enough, 5 Months later, this is happening to me now, but only after I got Nitro to change my banner...

  • TinyCthulhu

    Are they going to fix this or just wait a long time... The name change might work, but if the emote isn't from my server, there's nothing I could do about it. This is what I have nitro for and it has been a few months of most of my emotes not working... Nitro credit would be nice at this point. 😐

  • Awoc123

    I am thinking if another server has the same emote code as one of your emojis, it uses the other server's emoji for that code instead of yours.

  • AmeiLotus

    Y'all we already solved this... Please stop commenting lol

    Any emojis with the same emoji-code " :sadface1: for example will NOT work consistently with other emojis with the same name ":sadface1:". It will try to rename the emoji to something weird and it breaks. Have it renamed via the discord server it originated on, and you're good to go again.

    Symptoms: Trying to use an emoji and instead of the emoji, it just types it out and doesn't show any emoji.
    Footnotes: Does not affect *everyone* and it's very inconsistent. It's just discord shenanigans.

  • holiday

    Wait . . . No, why are we forgetting that this only happens on mobile? This legit is a Mobile only issue that has to do with it not reading Capitalization correctly when dealing with emojis.
    For example If you have a :Sadge: and a :sadge: or a :sAdGe: it will legit only read one correctly and cuase the others not to work the reason why it might not affect people is if they don't have enough servers in which similar names overlap and instead have the proper :Sadge: :Sadge-1: system. That being said if you also have a lowercase :sadge-1: and an uppercase :Sadge-1: the same rules apply. This is why even though I can't use half of my emojis from other servers becuase they have repeat naming at least 1 or 2 will work or if properly listed with the :emoji-#: than all of them work

  • Boneshock

    The issue happens when you have uploaded your own emoji to any server and the emoji shares a name with another emoji in a different server.

    To be clear. Let's say there's 3 people:

    You, User A, and User B.
    They all upload an emoji called ":test:" to different servers.
    Your emoji will always be output as plain text. However, when you select the emoji from User A and User B they will work fine.
    When you change the name of the emoji that you uploaded to ":testytest:" or something else, it will start working again.

  • Artoo

    Not entirely accurate in my case.
    One emoji is on three servers, none is mine.
    One is :Justright: and two are :justright: .

  • TheDarling🌹

    Yeah I also have that issue

  • Zorix

    Very frustrating bug, very rarely does it work, most of the time it fails spectacularly

  • slump6s

    It’s still like this

  • DanielisGamer

    This is becoming a problem for me cause some emojis are locked behind this for me, I really hope someone finds a fix for this soon cause I'm losing some of my favorite emojis to use

  • Pokebobbita

    This has been an issue for far too long. The main reason I have nitro is for the emoji, so this has been incredibly frustrating for me. Can Discord please fix this?

    (I have a Samsung Galaxy and my friend has the same issue on his Pixel.)

  • LC ඞ

    Same thing s happening to me and I am so pissed, its the only reason i got nitro now it aint working lol like seriously pls fix this thing or ill quit discord. it wont let me update the app as well ffs 🤦🏻‍♀️

  • hikiko.

    I found out a solution, or for me atleast, I believe the emoji name cannot be the same as any other, for me I had :cringe: which is common, so I changed it to something else and worked just fine

  • MAD7

    If any of you have had a issue using emotes on mobile, it's been a issue for Discord for a while now.
    I searched and searched and never found a answer.
    **Until Now!!**
    Used my little brain and my Super Powers of observation and discovered.....
    Capital Letters....
    If an emote has a capital letter, it won't work on mobile.
    Some exceptions of course , but...
    :example: works 100%

    Changed all my custom emotes in my servers and all test good on Android Discord Mobile.