Black screen during voice calls

評論

60 條評論

  • A Dandy Who Loves Lain

    Even with the latest update it stills happens the same problem in my cellphone, Discord needs to solve this problem soon

    1
  • 𝙆𝙚𝙫𝙤𝙧𝙚𝙭

    Guys stop this stupid thread!!! After an update during this covid pandemic (discord welcomes more non-gamer to use discord) discord default voice calls to using the same method that normal phone calls uses, which means only the speaker on the top of the phone is outputting sound, and that you're supposed to place your phone beside your ear in order to hear the voice. Discord made this change so that business people won't pick up the phone call exploding voices on the other side of the call during a meeting. Since phones nowadays got very loud top speakers, you guys that experiencing this problem all used the top speakers as if they are the loud main speakers. Just think of how you would do when you want to operate your phone when you are on a phone call. On the calling screen, you tap that speaker icon, and the main speaker turns on so that you won't need to stick your phone onto the side of your head to be able to hear the voice. And it's the same thing you need to do on discord now! Tab on that speaker button, select "speaker," and now the voices are louder and the freakin proximity sensor which tells the phone to black out the screen won't be detecting anymore.

    TL;DR
    Upon joining the call, tap on that speaker, and select "speaker." Unfortunately, we have to do this every time we join a call now.

    -5
  • 𝙆𝙚𝙫𝙤𝙧𝙚𝙭

    Welcome to copy the message above and spam it over anyone who still replies to this thread mentioning this "bug," which is never close to a bug at all.

    -6
  • 𝙆𝙚𝙫𝙤𝙧𝙚𝙭

    Oh and I just realized Discord planned this before the pandemic.

    -7
  • Haru testing stuff

    that's all very nice Kevorex, but this isn't about speakers, this thread is about your screen turning off when in voice chat. and putting it on speaker does not fix that

    3
  • 𝙆𝙚𝙫𝙤𝙧𝙚𝙭

    Huh, could you send me a proof that it doesn't work?

    -4
  • 𝙆𝙚𝙫𝙤𝙧𝙚𝙭

    You know how when we call and put out phone on our ears and the screen goes automatically off. It's just like that. If you are experiencing this issue even after switching the output to "speaker," then your phone must be very unique, and experiencing not what theses people above are experiencing. I suggest creating a new thread, and state that your phone's screen still goes off after switching the output to "speaker."

    -6
  • GTink911

    Also have this issue even after switching it to speaker. I use a Samsung Galaxy S7 with Android, so my phone is definitely not unique.

    1
  • WormyTheMagnificent

    @Haru Yesting Stuff, did you even try it? It worked for me, maybe it's a speaker bug or something?

    1
  • pawel

    have you guys fixed the problem? 

    1
  • Cloud

    Hello Guys,

    So, I am not the only one who faced that. Whatever I found a Solution for this unknown bug.

    -Go to your app setting> select discord>then go to app permission> then turn off your "camera" permission > reboot your phone.

    You can turn on your camera setting if you need to. But while multitasking makes sure it's off.

    That's all. Its worked for me.
    Thanks.

    0
  • HarumiMiharu

    I just tried that Cloud, on two phones even, didn't work on either one :, (

    1
  • 𝙆𝙚𝙫𝙤𝙧𝙚𝙭

    What phones are you using? Two phones and none worked? Try plugging in earphones or connect to bluetooth earphones/speakers. If it doesn't turn black while connected with to external devices, then it's not discord's problem. It the problem persist, then I believe you really have to wait for discord to "fix" it, which I believe would never come, because this issue is basically impossible to replicate on a normal phone, and that you guys on here don't even tell the manufacturers, devices name and OS versions of your phone. I'm not affiliated with discord in any way, but I found this thread absurd.

    -6
  • Cloud

    Okay, I just noticed that some of the users are facing the same problem but they solved their problems in different ways. In a previous comment, I saw someone fixed his problem just by turning off the auto sensitivity and some of them just plug their headphone to get rid of it. So, I just shared mine. HarumiMiharu

    And I also noticed that there is a sensor or something when you move your hand over the camera the black screen appears on my mobile.

    For now, I am thinking that's a discord issue on the android app because when I use discord on PC, I never faced any type of problem like this. 

    And Kevorex this thread is not absurd, If people are not facing this problem they won't waste their time to comment and find a solution here.

    1
  • 𝙆𝙚𝙫𝙤𝙧𝙚𝙭

    Discord calls by default work the same way as normal calling, in which we have to place our our phones onto our ears. Yeah that's right. A lot of people don't know how to switch discord calls into hands-free mode, and as I state above, we'll need to tab on that speaker button, select "speaker," everytime we call. And yes, Cloud, your method of blocking discord from accessing the proximity sensor works, and that we don't necessarily need to switch to "speaker" output this way, but people keep saying this method doesn't work, that method doesn't work, without even posting their devices and OS versions, and that's why I found this thread mind-blowing, cuz like how is the discord team gonna "fix" it if they don't know how to replicate it.

    -4
  • IRIDIUM86

    My solution for this shit, do what cloud and kevorex said. And done! (If one of them still not work why don't you use both? Logic!

    -3
  • ㅂㅏㅌㅂㅂ

    Finnaly I found a soultion. FIX HERE LOOK HERE. IT'S THE sensor at the top of your phone. Don't believe me? Go on a call and put your hand on the sensor and see for your self

    -1
  • Zeronil

    If you read the entire thread you would have realised to some phones that doesnt work...

    3
  • 𝑉Ǝ𝑁𝑇 • 𝕌 𝔹 𝔼

    hi so i might just have the fix for you guys! Im not sure if this works for iphone but it does work on samsung which in my case the samsung a21. basically all you have to do is unlock your developer options which you can search in YouTube to know how, once you've opened your developer options look for " quick settings developer tiles" and when you open that youll see a list of things you can turn on or off but at the very bottom of the list you should see "sensors off" you just have to turn that on. The very last step you do is slide down from the top of your screen to open your notification bar and press the newly added "sensors off" and once you press it, it should turn blue and now you can go on any call on discord without having you screen go black because of the sensor.

    2
  • 𝑉Ǝ𝑁𝑇 • 𝕌 𝔹 𝔼

    hope it works for you guys too!!

    0
  • Captain noob

    I have this problem too. Whenever I need to be in my on duty voice call when I'm playing a military game, my screen goes black. It makes it harder to chat and press GUIs. I can't even get out of the call...

    0
  • Zade-Sama

    I have this problem too, it's not like the screen sleeps or anything, it seems to just turn off completely. I don't know if it's because I can't find a way to wake up the screen but it honestly annoys me so much...

    1
  • Zade-Sama

    Okay I have found a fix for this problem :
    Covering the camera and uncovering for some reason seems to turn it on sometimes
    I honestly think it's something to do with in-app camera optimization making the 'sensor' not realise when we are holding our phone to our ear because on apps like Snapchat, Tiktok etc... androids have poor quality due to lack of optimization so I feel like the sensors are failing for some phones that Discord didn't optimise for but that's just my theory 🤷‍♂️

    2
  • Holmes

    Same here, my android does this for all my calls. Just put it on speaker and you'll be fine

    0
  • RoBoTiC119

    The flashing is due to an update that added a proximity sensor for discord at the top of a mobile device. In order to disable this and fix the black screens, do the following:
    When entering the voice chat there is a speaker icon option at the bottom of the screen. Click on this icon and change the setting from Phone to Speaker.

    0
  • Paper

    𝑉Ǝ𝑁𝑇 • 𝕌 𝔹 𝔼 It kinda works but I can't speak anymore when the mode is enabled so..

    0
  • 「☂」

    This has been happening with mine as well and it drives me crazy.
    It bothers me so much-
    If this could be fixed that would be great ngl

    0
  • JJyourdude

    This is Exactly my problem, i will be in voice chat or a call on a server and it turns off for no reason and rapidly, what do i do?

    0
  • Muchhad

    Found it..! Go to voice and video, scroll to the bottom and select the option stating 'force calls NOT TO USE open sl es' it worked for me, theres no harm in giving it try yourself

    1
  • leonardocaesar

    If you have a iphone try turning off low power mode

    0

登入寫評論。