[Windows] auto start problem (and fix)

Comentarios

42 comentarios

  • pxpcandy

    This isn't an issue. Discord automatically starts because it's on your startup list on the task manager. Just disable it from there, there's absolutely no need to go through the trouble of all this.

    -109
  • masterfelu

    @zusk did you read the post or just made a comment by reading the title?

    48
  • Chameleon

    pxpcandy

    u better stfu, i have problem of this - task manager shows me discord as running but dont show me it in on startup applications so I aint able to turn it on, even I reinstalled it all and all settings in discord is on

    9
  • Steffen

    I can confirm Chameleons experience.
    Discord no longer shows up in the startsection of task manager.
    It is, in short, impossible to turn autostart off (or on, although I fail to see why one would need to do so, for a programme that simply chooses to autostart without bothering to ask)

    Luckily, there's a very solid quickfix for this: uninstall Discord.
    Done and done.

    -4
  • rubenayla

    I can confirm having the same problem on a fresh Windows 10 installation. We know that windows is a mess, but please discord, don't contribute to the messiness! A simple on-off switch in the settings to configure the auto start-up would be enough.

    3
  • masterfelu

    op here. this is how i fixed my problem:

    1. download autoruns from here: https://docs.microsoft.com/en-us/sysinternals/downloads/autoruns 
    2. extract > open folder > right-click Autoruns/Autoruns64(depends on ur os) > run as administrator
    3. find discord > right-click > jump to entry
    4. double-click Discord
    5. Put the file-path in value data in quotes.
    6. press ok > restart pc
    7. also u can check from startup section in task manager. there will an entry for discord:
    8. alternatively, u may wait for the devs to fix it.
    15
  • Totowow

    I did the fix above editing registry manually with no utility programs. I didn't restart my computer yet but I can see a slight difference in task manager: it shows "Update.exe --processStart Discord" with no publisher. I dunno if this fix works for me

    7
  • genious 7

    Hi,

    I can confirm the issue. On username with spaces, discord fails to add the quotes to the startup registry entry, which is why it won't startup despite the setting being activated. On username without spaces, it isn't an issue, which (I guess) is how this issue got past Q/A.

    1
  • Hipster1298

    genious 7 i dont have spaces in my username but discord wont start on startup

    1
  • Hipster1298

    masterfelu thanks ur fix worked, the only thing is I had to look in my files to change the file path because it was called "Update" before for some reason

    3
  • Hipster1298

    masterfelu actually it fixed the problem temporarily. Everytime I restart my pc the file path will just change back to what it was before so it'll change back to "Update" by Github in Task Manager but at least now I know that "Update" is actually Discord

    8
  • masterfelu

    Hipster1298 can you share screenshot of the Autoruns application?

    0
  • Hipster1298

    This is what it shows for Discord on the Autoruns application. I drew over my username.

    0
  • masterfelu

    Well, there is no whitespace character in your username it seems, which was the reason the problem happened for me in the first place. I do not know what is the problem you are facing, but just to careful, make sure only the file path is in wuotes and not the entire command.
    Cheers!

    0
  • Zapa

    Hey all!

    I had the same problem than Hipster1298 and It is due to a missing key in the registry that prevents Discord to load on Windows startup. That update.exe is not even the program executable. That is a secondary program to (obviously 😉) check for Discord new versions on startup and update it.

    So, the thing is that the actual key to load Discord on Windows startup is just missing and in order to fix it we will have to add it manually to the registry.

    Careful! If you are not used to touch the Windows registry you better wait for a fix in next updates!! Do it at your own risk! If you touch something wrong you can break your system which I will not be held responsible of.

    First of all we have to copy the route to the discord executable. The best way to do this is open a File explorer windows and navigate to C:\Users\<YOURUSERNAMEHERE>\AppData\Local\Discord\

    There you will see several folders with different versions of Discord. Double click on the last one

    Then click on the upper bar and it will show your current route. Just Ctrl+C to copy it to the clipboard

    Time to go to the registry editor. Click the magnifying glass and type "regedit" to easily find it and click on it.

    So, once we load the registry editor we have to search for the branch where all programs load at Windows startup which is 

    Computer\HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Run

    We click the "Run" folder to see the contents and then click secondary mouse button in an empty space at the right window to open contextual menu.  We click on "New" and then "String"

    That will create a new key. We put the name we want (except discord). I put Discordprog to identify it easily

    Now double click on the new key to open it and we paste the route at the text box and add Discord.exe at the end. If your username has blank spaces you will have to add quotation marks at the beginning and the end of the route which was not my case.

    Click OK and that is all. That key won't be altered because we have added it manually.

    Very important! When Discord fixes this WE WILL HAVE TO REMOVE THIS KEY MANUALLY.  We just open regedit, find the Run folder, find our key and press Supr key to delete it after confirmation.

    Hope it helps!

    10
  • Cristhian Reinoso

    Zapa's solution is just perfect, if you're having troubles with Discord auto-starting with Windows, just follow the steps

    1
  • Hipster1298

    Zapa could I just change the original string to the correct value? I've been putting quotation marks around the file path and "-processStart Discord" at the end, is that not necessary?

    0
  • Zapa

    Hipster1298 As I understood from your original post that "original stream" is missing and instead you only see the "update" registry key.  I think they are not the same.

    Of course I could be wrong and maybe that key is for the two purposes (update and start Discord) but since it is not working I prefer to "force" the startup with a new key.

    So, it is ok to have the update key in order to check for updates on startup but if you want discord to load on startup you will have to make a manual entry on the registry with the instructions I have provided. At least until Discord fixes it in a future version.

    When Discord fixes it you will have to delete that manual entry. Elsewhere you will have a duplicate entry (not good 😁).

    0
  • Kiwi~

    I found the easier way and tested it from Microsoft...

    Add an app to run automatically at startup in Windows 10

    Windows 10
    1. Select the Start  button and scroll to find the app you want to run at startup.

    2. Right-click the app, select More, and then select Open file location. This opens the location where the shortcut to the app is saved. If there isn't an option for Open file location, it means the app can't run at startup.

    3. With the file location open, press the Windows logo key  + R, type shell:startup, then select OK. This opens the Startup folder.

    4. Copy and paste the shortcut to the app from the file location to the Startup folder.

     

    I did this with my discord.exe and it works. Just find the program and you good to go.

    16
  • Hipster1298

    @Kiwi~'s solution is perfect, I didn't want to zapa's solution because I thought that I would forget to delete the new key later on.

    2
  • GC9.

    I can also confirm that Kiwi~'s solution works perfectly well. However I do still feel like Discord devs should try and sort this out as soon as possible.

    3
  • Dannyton29

    I found the solution, while reading through this thread I saw that Hipster1298 said something about discord being called by update by github. Once I enabled it and restarted my pc it started working again. Please make sure you have "Update" by github enabled

    13
  • Zhu

    Hey peeps, PLEASE UPVOTE Dannyton29's solution. For clarification, one can do this by going back to the Startup tab in Windows Task Manager, find the "Update" entry by GitHub, and then select Enable. Restart Windows and you should be good to go!


     

    Oh yeah, Discord, y'all really DO need to get up to speed here on proper Windows packaging. Been out there way too long for this to remain excusable. PLEASE PRIORITIZE. Thank you.

    13
  • Hipster1298

    Zhu both Dannyton29's and Kiwi's solution work so upvote both

    2
  • Potehto

    Have tried all the solutions but none of them seem to work for me :( I now have two of Discord and one of Update in my startup Window, and none of them seem to work regardless of which I enable, whether it's only one of them, or one of Discord and one of Update, or just Update without Discord, nor just Discord either.

    Have restarted my PC multiple times to try it too I think at this point I'm ready to throw in the towel and just accept that I'll just have to launch Discord manually on startup every time, no big deal, just would be nice if it would've been able to launch on startup on its own. Settings to launch on startup in Discord's own Windows Settings are all enabled either and still nothing.

    Funny how they charge $9.99 for Nitro and can't even get something like that right :/

    1
  • Zhu

    Hi  Potehto! That sucks! The double Discord entry in Startup seems concerning. Have you tried uninstalling Discord and then manually nuking the discord folders under AppData\Local AND AppData\Roaming as well? Not sure if that'll take care of Update too. Then a Windows restart and reinstall for good measure.Best wishes!

    2
  • Zhu

    Hipster1298, I don't disagree however as easy a solution as Kiwi's is, it IS a workaround insomuch as a successful install of Discord should handle that automatically. That is does NOT indicates another issue which may crop up again later. Always best to attempt to get things to work the way they were intended if at all possible. ;)

    2
  • shadowunicorn38

    @Kiwi~ 's method worked perfectly and is very simple

    0
  • Lunaris

    Hi, All! I spent 72-hours trying to fix "Discord doesn't start with Windows 10," and found something in my scenario not mentioned here. I followed Discord's instructions to remove all traces of the program, going as far as to remove C:\ProgramData\SoftwareDistribution folder, as well as the recommended %locaAppData% and %AppData% Discord folders. I also found other tips to remove Registry entries for Discord at Computer\HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Run, Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run, and even Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows\CurrentVersion\Run (if present). All in all, I could not reinstall Discord (multiple tries), until I restarted in Safe Mode + Networking (⊞+R > "msconfig"). After installing in Safe Mode + Networking, Discord still did not AutoStart with Windows 10. Here's how I fixed:

    1. Open TaskManager (CTRL+Shift+ESC)
    2. Left-click Tab "Startup"
    3. Right-click Entry "Update|Github"
    4. Left-click Dropdown Menu Item "Properties"
    5. Left-click Tab "Compatibility"
    6. Left-click Button "Change settings for all users"
    7. CLEAR Checkbox "Run the program as an administrator"
    8. Left-click Button "OK"
    9. Left-click Button "OK"
    10. Restart PC

    I think when trying all of Discord's recommendations I set Discord to "Run as administrator" and ran the installation file as administrator. I confirm that the "Run as Administrator" flag STAYED ON after uninstalling/deleting/reinstalling. Removing the flag and returning to default behavior (so long as you are actually logged into your admin account) worked for me. Hope this helps someone.

    2
  • HxteM3

    Really have no idea if this will help anyone... but I looked in startup services and couldn't find Discord. I did however see "Update" by GitHub and it was disabled.. realized this was actually for Discord after opening file location.

    9

Iniciar sesión para dejar un comentario.